Bevezető

Kedves szülők, Tisztelt pedagógusok!

Talán mindannyian egyetértünk abban, hogy gyermekeink írás-olvasás készségüket – akár anyanyelvükön, akár idegen nyelven – egyéni képességeikhez igazodó tanítással tudják elsajátítani a leghatékonyabban. A számítógép lehetőséget ad arra, hogy a gyermek egyéni ütemben haladjon. Ez a lehetőség új pedagógiai szituációt teremt és használata számos gyermeki attitűd pozitív változását eredményezi.

E tapasztalatokra építve kezdte meg kutatásait Rachel COHEN francia professzorasszony munkatársaival az 1980-as évek elején. Megfigyeléseik hat tanéven át folytak, iskolai kísérleteikben több ezer francia kisiskolás, óvodás vett részt. Azóta a számítógép használata a kicsik anyanyelvi és idegen nyelvi nevelésében már több országban megkezdődött és elterjedt. A gyerekek már óvodáskorban találkoznak a számítógépekkel otthon vagy szüleik munkahelyén. Nem mindegy azonban, hogy milyen útmutatás alapozza meg az informatikai eszközökkel való ismerkedést. Nekünk felnőtteknek kell arra nevelnünk gyermekeinket, hogy értelmes alkotó gondolataik kifejezésére használják az informatikai eszközöket. A kísérlet eredményei az olvasás, a szövegértés, valamint írásképesség látványos javulásában volt nyomon követhető.

A Lapoda Mese egy egyszerű rajzoló programhoz hasonlítható, azzal a nem jelentéktelen különbséggel, hogy nem várja el a gyermektől, hogy képes legyen az egér segítségével rajzolni, hanem kész elemgyűjteményből kell neki kiválasztani a figurákat (állatokat, embereket, tárgyakat). A régi jól ismert nyomdázáshoz hasonlítható ez, de itt a gyermek a megfelelő ábrát nem látványa alapján választja ki, hanem nevének kiválasztásával vagy beírásával. Ez a játékos „kényszer” segíti a gyermekek olvasási és írási készségének fejlődését. Az elkészült remekművek elmenthetők, illetve később visszaolvashatók. Lehetőség nyílik a munka kinyomtatására is. A színes nyomtatás – fekete-fehér nyomtatókon szürke árnyalatos képet adva – mesekönyvek, míg a fekete-fehér „körvonalas” nyomtatás kifestőkönyvek készítését teszi lehetővé.

A Lapoda Mese akár egyénileg, akár kiscsoportos foglalkozás keretében is felhasználható. Tulajdonképpen egy rendkívül egyszerű kis kiadványszerkesztőnek fogható fel, mellyel a kicsik a saját mesevilágukat építik fel. Rajzaikat magyar vagy idegen nyelven írott szövegeiket kinyomtatva, átszínezve képeskönyvet készíthetnek.

Fő törekvésünk a Lapoda Mese programot főként az általános iskolákba és a megfelelő technikai felszereltséggel rendelkező óvodákba eljuttatni. A szoftver fejlesztésénél az volt a célunk, hogy a gyermekek egy olyan oktatóprogramot kapjanak kézhez, melynek segítségével különösebb erőfeszítés nélkül, tudnak alkotni, tanulni. Ismerve az iskolák anyagi helyzetét és számítógéppel való ellátottságát, a programot úgy fejlesztettük ki, hogy a fellelhető gyenge gépeken (kb. Pentium I-es gépek) is lehessen használni.

Kiemelt lehetőségek

  • Többrétű felhasználás: olvasás/írás tanítás; idegen nyelv tanítás; mese hallgatás
  • Hangrögzítés - lejátszás
  • A rajzok elmenthetők - visszatölthetők
  • A rajzok kinyomtathatóak színesben, illetve körvonalasan
  • Beépített közvetlen Internet kapcsolaton keresztül a rajzok frissíthetők, bővíthetők


A program futtatatása

A program használata

A program egyszerű indításához a telepítése során ún. parancsikonok készülnek a Windows Asztalon és Start menübe.

A program indítása után megjelenik a nyelv- és funkció választó menü. A használat során az ábrák neveit, majd az itt kiválasztott nyelven lehet olvasni. Alapbeállításként ez a nyelv az angol, de a program újbóli futtatásakor "emlékszik" a korábban használt beállításra. A továbblépéshez kattintsunk duplán a lista (1) kiválasztott elemére vagy nyomjuk meg a jobb alsó sarokban található (2) gombot.

A program speciális beállításait és bővíthetőségét biztosító funkciók csak a program "mester" jogosultsággal rendelkező regisztrált felhasználóinak állnak rendelkezésre. A regisztráció dialógus ablakát a (3)-as nyomógomb nyitja. A speciális beállításokhoz a (4)-es gomb lapoz, míg az (5)-ös gomb a figurák és témakörök bővíthetőségét teszi lehetővé.

A (2)-es gomb megnyomásával a program munkafelületére érünk.

3: | Új mese létrehozása
4: | Korábbi mese megnyitása
5: | Mese elmentése
6: | Szólista láthatósága
7: | Körvonalas nyomtatás
8: | Színes vagy tónusos nyomtatás
9: | Témakör választás
10: | Figura név
11: | Figura név lista
12: | Vissza a nyelvválasztáshoz
13: | Jelenet eldobása
14: | Új jelenet létrehozása
15: | Rajzlap (aktuális jelenet)
16: | Panel méret beállító
17: | Jelenet hangfelvétel
18: | A jelenet szövege
19: | Előző jelenet
20: | Filmszalag (jelenet lista)
21: | Következő jelenet
22: | Figura mozgatása, hanglejátszás
23: | Figura előre hozása
24: | Figura hátra küldése
25: | Figura nagyítása
26: | Figura kicsinyítése
27: | Figura tükrözése vízszintesen
28: | Figura tükrözése függőlegesen
29: | Figura elforgatása
30: | Figura törlése
31: | Program frissítés az Internetről

Láthatjuk, hogy a munkafelület gyerekeknek készült, a kezelő gombokat úgy alakítottunk ki, hogy a gyermek számára barátságos környezetet és a még bizonytalan kezek számára is megfelelő kattintási felületet biztosítsanak.

Induláskor a képernyőn egy üres rajzlap (15) jelenik meg, melynek mérete a program ablakának méretéhez igazodva változik. A kényelmes használathoz célszerű az ablakot a lehető legnagyobb méretben megjeleníteni a programfejléc jobb oldalán található "Teljes méret" gombbal.

A bal alsó sarokban található (12) gomb segítségével a főmenübe térhetünk vissza, hogy esetleg nyelvet váltsunk. A programból való kilépésre használjuk az ablak jobb felső sarkában lévő "bezárás" gombot vagy a Windowsban megszokott Alt+F4 billentyűkombinációt.

A mese előállításához a "Szerkesztési műveletek" útmutatását kövessük.

Fájlkezelő gombok: (3) - (5)

Az új mese készítése tulajdonképpen a szerkesztő felület és az oldal filmszalag kiürítését jelenti. Természetesen ha az aktuálisan szerkesztett munka még nincs eltárolva a törlés előtt egy mentésre figyelmeztető dialógus ablak ugrik elő. Ha a mentési kérdésre igennel válaszolunk egy újabb kérdező ablak jelenik meg a munka nevével (lásd a mentésnél).

A mese megnyitásakor egy dialógus ablak nyílik ki, melyben a korábban elmentett mesék gyűjteménye jelenik meg. A könnyebb kiválasztáshoz a mesék nevét az első oldalaikról készült gyorsnézettel illusztrálja a program. A mese megnyitása az előnézeti képre való dupla kattintással történik. Abban az esetben, ha a mesegyűjtemény nem fér ki egy lapra, az automatikusan megjelenő gördítősávval lehet a többit előhozni.

A mese mentésekor egy kérdező ablak jelenik meg, mely felkínálja a mese jelenlegi nevét. Ha a mesénknek nincs neve, ez a mező üresen áll. Amennyiben a mezőben szereplő nevet jóváhagyjuk, a változások a korábbi névvel lesznek elmentve, ha viszont a nevet megváltoztatjuk, az adott névvel egy új fájl keletkezik.

Filmszalag

Lehetőség van egy mesét több jelenetből felépíteni. A jelenetek önálló rajzlapokra kerülnek. Egyszerre csak egy rajzlap szerkeszthető. A szerkeszteni kívánt rajzlap kiválasztására több módszer is kínálkozik.

a, A filmszalagon kattintsunk a megfelelő jelenet diaképére. Amennyiben a mese több jelenetből áll, mint amennyi a filmszalagra kifér, a filmszalag gördíthetővé válik. A filmszalag gördítéséhez nyomjuk le az egér bal gombját. Az egérgomb lenyomása mellett mozdítsuk el az egeret jobbra vagy balra és a filmszalag elcsúszik a megfelelő irányba. A filmszalag az elején és végén kiütközik, vagyis nem lehet tovább gördíteni.

b, A jelenet kiválasztásának másik módja a filmszalag két végén található lapozó nyilak használata. Ezek nyomogatásával lehet egy jelenettel előre vagy hátra lépni.

Oldalakkal kapcsolatos műveletek

 Új oldal létrehozása.
Az aktuális oldal mentése után tiszta rajzlapot kapunk és a filmszalag végén egy új cella jelenik meg. Amennyiben a gomb megnyomásakor a Ctrl billentyűt is lenyomva tartjuk, az új jelenet lemásolja a aktuálisat. Ez igen hasznos, ha csak kis módosítást akarunk elvégezni. Ha a Shift billentyűt is lenyomva tartjuk hozzá, az új jelenet nem a filmszalag végére kerül, hanem közvetlenül az aktuális jelenet után, eltolva a többit.

Az aktuális oldal törlése. A törlés után a kijelölés a törölt rajzlapot megelőző lapra kerül, illetve az első lap törlésekor a másodikra. Mivel a mesének legalább egy lapot mindenképpen tartalmaznia kell, az utolsó (egyetlen) lap törlése csak annak tartalmát törli.

Oldal áthelyezése: ha a diakép vonszoláskor lenyomjuk a Shift billentyűt, akkor a képet másik helyre helyezhetjük át.
Oldal másolása: a diakép vonszoláskor a Ctrl billentyűt lenyomva, a megragadott jelenetet egy másik diaképre rádobva a tartalmat átmásolhatjuk az új helyre.

Mese írása

A rajzokhoz mese is írható a munkafelület alatt található jegyzet felületbe. A mese szövege több soros is lehet, új sort a billentyűzet ENTER billentyűjének lenyomásával lehet kezdeni. A szöveg a Windows vágólap használatával más szöveges alkalmazásból is átemelhető. A vágólapon "hozott" szöveg beillesztéséhez a jobbgombos menü Beillesztés pontja használható vagy a Ctrl-V billentyűkombináció.

Rajzok nyomtatása

Csak abban az esetben használható ez a funkció, ha a számítógéphez telepített nyomtató csatlakozik!

 A rajzlap színes nyomtatása. Fekete-fehér nyomtatókon a színek szürke tónusozással lesznek kinyomtatva.
A rajzlap kontúros nyomtatásával egyszerűen lehet kifestőkönyvet készíteni. Ennél a nyomtatási módnál az ábrák színes felületei a világosságuktól függően lesznek fehérek vagy feketék.


Szerkesztési műveletek

A szerkesztési műveletek ikonjai a munkafelület jobb szélén, egy panelen találhatók egymás alatt. Egyszerre csak egy műveltet hajthatunk végre. Az éppen aktuális funkciót a gomb benyomott állapota jelzi.

Elem elhelyezése a rajzoló felületre

Kezdjük a munkát a témakör kiválasztásával. Ehhez a bal felső gombsor alatti legördíthető mezőt (9) kell használnunk. A legördülő listában a rendszerben pillanatnyilag elérhető témakörök felsorolását (pl.: mese, állatkert, cirkusz, kirándulás, stb.) láthatjuk – ezek a témakörök később az Internetről (31) továbbiakkal bővíthetők.

A témakör kiválasztásával a témakör alatt elhelyezkedő ábra listában (11) megjelennek a témakörhöz feltöltött figurák megnevezései – a korábban kiválasztott nyelvnek megfelelő formában. Ha az egérrel valamely szóképre duplán rákattintunk, akkor a szóképnek megfelelő rajz megjelenik a rajzlap (15) közepén. Ezt – és majd később a többi figurát is – az egérrel történő vonszolással a rajzlap bármely más részére áthelyezhetjük. A rajzok tetszés szerinti számban előhívhatók, ugyanaz a rajz többször is megjeleníthető (pl.: fű elemekből lesz rét vagy fákból erdő). A később behívott rajz a korábbiakra helyezve lefedi azt. Részbeni lefedésekkel is igen ötletes rajzokat tudnak kitalálni a gyermekek. A figurákon számos utólagos átalakítás (transzformáció) is végrehajtható. A programnak ez a része a szóképek felismerését, bevésődését segíti.

A figura lista felett található szöveges mezőbe (10) történő előgépeléssel a lista tartalma szűkíthető a beírt szöveggel kezdődő nevekre, illetve azokra, amelyekben a beírt részlet egyáltalán szerepel. Ez utóbbi nevek a listában halványabban jelennek meg (pl.: a h begépelésével a listában marad a házikó és a herceg. Halványan ugyan, de látszik a kunyhó is a benne lévő "h" miatt, de eltűnik az összes olyan név melynek semmi köze a "h"-hoz). Ez a funkció már az írást gyakoroltatja, a helyes íráskép látványával pedig segíti a szó képi berögződését.
A listában még egy dologra felfigyelhetünk. A házikó mellett egy rajzlap ikon jelenik meg, ami azt jelzi, hogy az illető név nem figurát, hanem háttérképet takar.

A témakör kiválasztó mező feletti lista (6) nyomógomb segítségével a figurák neveit tartalmazó lista eltüntethető. Ez a funkció a helyes írásra fogja kényszeríteni a gyerekeket, mivel a program csak a pontosan beírt megnevezéseket fogadja el. A lista az említett gomb újbóli megnyomásával előhívható. Pedagógusok figyelmébe: a program paraméteres indításával (lásd a súgó megfelelő fejezetében) lehetőség van ennek a gombnak a letiltására.

Elem mozgatása

Ha erre az ikonra kattintunk az egérrel, akkor a munkafelületen mozgathatjuk a kiválasztott elemet. Ez úgy történik, hogy a mozgatni kívánt elemre rámutatunk és az egérgombot lenyomva elvonszoljuk a figurát egy másik helyre. A kívánt helyen egyszerűen engedjük el az egér gombját. Amíg a figurát "tartjuk" az egérmutató fogó kezet mintáz.

Figyelem! A rajzlapról teljesen lehúzott figura elvész, mintha töröltük volna.

Figura előrehozása és hátraküldése

Ezekre a nyomógombokra akkor van szükségünk, ha egy oldalon több objektummal dolgozunk, mivel ezek a lapra helyezés sorrendjében helyezkednek el egymás fölött. Ennek a "kitakarási" sorrendnek a megváltoztatása lehetséges az említett gombokkal. Használatuk igen egyszerű: kattintsunk a megfelelő műveletre, majd arra a figurára, amelyre alkalmazni szeretnénk. Ezek a műveletek a figurákat egy lépésben viszik a lap tetejére vagy legaljára, ezért a kívánt elrendezéshez a művelet többszöri, több figurán történő alkalmazására is szükség lehet.
Egy trükk: a funkciógombokat "beragaszthatjuk" a többszöri alkalmazáshoz, ha a Shift billentyűt lenyomva tartjuk miközben a műveletet végezzük. Ha így teszünk a műveleti gomb nem fog visszaugrani a figurára kattintás után. Ebből az állapotból a kéz-forma gombbal lehet kihozni a programot.

Nagyítás és kicsinyítés

Ezekkel a gombokkal nagyíthatjuk és kicsinyíthetjük a rajzoló felületen lévő figurákat. Egyszerre csak egy elem méretét változtathatjuk, de a műveleti gombok "beragasztásával" (lásd az előző pontot) többször is elvégezhető.

Figura tükrözése

Ezekkel a gombokkal a kijelölt figurát vízszintesen, illetve függőlegesen tükrözhetjük. Minden képre melyet meg szeretnénk fordítani, külön kell kattintanunk. Ezek a műveletek egy elemre csak egyszer alkalmazhatók, hiszen a második fordítás után a kiindulási helyzetet kapjuk vissza.

Figura vagy háttérkép törlése

A feleslegessé vált figurákat úgy törölhetjük, ha egyszerűen lehúzzuk a rajzlapról vagy a radírral jelzett műveletet alkalmazzuk rájuk. A művelet – a többihez hasonlóan – "beragasztható" ha egymás után több ábrát akarunk törölni. A figura törlése egyben a figurához rendelt hangfelvétel (ha van) törlését is jelenti.
Ha a rajzlapon van betöltött háttérkép, annak törlése a radírral történő rákattintással történik. Vigyázzunk arra, hogy ha figurát akarunk törölni, de az egérrel nem találjuk el annak "tartalmát", a háttérkép esik áldozatul!


Hangfelvétel készítése

Hangfelvétel készítése és lejátszása

A program hangfelvételek készítésére és lejátszására is alkalmas. A mesében minden jelenethez és a jelenet figuráihoz külön-külön is hangfelvételek kapcsolhatók. A hangfelvételek alkalmazásához természetesen hangkártyával ellátott számítógépre és a felvételhez a hangkártyához csatlakoztatott mikrofonra lesz szükség. A hangkártya a számítógép (manapság széria tartozék) bővítménye. Az újabb típusoknál ez a funkció már eleve az alaplapra van integrálva, de egyes esetekben a külső hangfelvevő egység is előfordulhat. A mikrofon csatlakozóját a legtöbb esetben mikrofon szimbólummal vagy rózsaszín jelöléssel látják el a gyártók.

A hangfelvétel készítésének menete:

a, Az eszközök közül (jobb oldali panel) nyomjuk meg a mikrofon gombot. Ilyenkor az egérkurzor mikrofonra változik.

b, Az egérrel kattintsunk arra a figurára, amelynek a szövegét fel szeretnénk mondani vagy a jelenethez tartozó hang felvételéhez a szövegdoboz melletti hangszóró jelre.

c, A hangfelvétel tényleges elkészítésére az alábbi kezelőablak nyílik meg:

d, A felvétel a mikrofon gomb megnyomásával indítható. A felvétel közben a gombon villogni kezd a mikrofon szimbólum. A gombsor alatti kivezérlés jelzőn ellenőrizhető a jelszint, az alatta lévő potenciométerrel pedig a mikrofon erősítése szabályozható. A helyes felvétel készítéséhez igyekezzünk a jelszintet a sárga tartomány közepén - kétharmadán tartani. A gyenge jelszint esetén a felvétel halk és zajos, míg magas jelszint esetén pedig túlvezérelt, azaz torz lesz. Felvételkor a mikrofont ne tartsuk túl közel a szánkhoz, mert ez "csámcsogási" hatást okoz. Ne féljünk kiereszteni a hangunkat és határozottan, tagoltan beszélni!

e, A felvétel leállításához újból nyomjuk meg a mikrofon gombot. A felvétel lezárását követően aktívvá válik az a két gomb, melyek a felvétel közben szürkék voltak. A zöld pipa a felvétel elfogadását és MP3 formátumúvá alakítását jelenti. Az MP3 konvertálás ideje alatt a kivezérlés jelző kék színűre vált és a konvertálási folyamat százalékos készültségi állapotát mutatja. A piros kuka, azaz felvétel eldobása, egyben azt is jelenti, hogy az adott figurához vagy a jelenethez nem tartozik majd hangfelvétel. Ha a felvétel nem sikerül a d, pontban leírtak szerint új felvétel készíthető.

f, Amennyiben előre felvett hanganyagot vagy zenét akarunk használni, a mikrofon melletti tallózó gombot megnyomva tudjuk a fájlt kiválasztani. A tallózó a program Sound mappájában található fájlokat kínálja fel, tehát ha a fájl máshol van, előbb másoljuk át ide. A tallózó MP3 és WAV formátumú hangokat fogad el. Az utóbbi esetben a felhasználáshoz automatikusan konvertálja a hangállományt.

A program regisztrált változatában beállító mezők sorát is használhatjuk, melyek jelentése a következő:

1, Ennek a beállításnak akkor vesszük hasznát, ha azt akarjuk, hogy a felvétel automatikusan induljon el, amikor az adott oldalra lapozunk. Egy oldalon egyszerre csak egy hangnak lehet ilyen tulajdonsága!

2, Az újrakezdéssel folyamatos lejátszás érhető el. Ez tipikusan aláfestő zenéknél, hang-effekteknél hasznos.

3, Szintén hasznos lehet, ha például az első oldalon automatikusan elindított zene a lapozáskor nem szakad meg, hanem végigkíséri a mesét.

4, Amikor fontos az, hogy a figurára kattintva szólaljon meg annak hangja még akkor is, amikor még az előző lejátszását sem fejezte be, tegyünk pipát ebbe a mezőbe.

5, A hangfelvétel végén automatikus lapozás is elérhető ennek a mezőnek az aktiválásával. Az utolsó oldalon, amikor már nincs hova lapozni, a program bezáródik, hacsak nincs körkörös üzemmód beállítva, ugyanis ebben az esetben újból az első lapra jutunk.

A hangfelvételek lejátszása

A jelenethez tartozó hangfelvételt – amennyiben van – a jelenet szöveg mező melletti hangszóró szimbólum színes állapota, a figurákhoz tartozó hangokat pedig hangszórós egérkurzor jelzi. A felvétel lejátszásához csak egy kattintás szükséges. Azért, hogy a mese a hangok tárolása ellenére is kezelhető és hordozható méretű maradhasson, a program mind a képeket mind a hangfájlokat tömörítve tárolja. A hangtömörítéshez a napjainkban oly divatos MP3-nak nevezett eljárást alkalmazza. Ezt az eljárást a Windows 2000 és Windows XP rendszerek alap kiépítésben tartalmazzák, vagyis ilyen gépeken a lejátszásnak semmi akadálya. A Windows 98-as kiadásán azonban a MediaPlayer friss változatának telepítése szükséges az MP3 lejátszási képesség eléréséhez.

A hangfelvétel törlése

A már elkészített hangfelvételtől úgy lehet megszabadulni, hogy felhívjuk a hangrögzítő ablakot a c, pont szerint és a kuka gomb használatával eldobjuk a felvételt.


Hangfelvétel készítése

A program bővítése

A program lehetőséget ad a kezelőfelület szövegeinek módosítására, nyelvi változatok készítésére, valamint a témakörök bővítésére. A kezelőfelület feliratai, üzenetei egyszerűen módosítható külső állományokban vannak. A módosítások elvégzéséhez elegendő akár a legegyszerűbb szövegszerkesztő is, pl. a Windows Jegyzettömbje (notepad.exe).

A kezelőfelület nyelvi definíciói a program system mappájában található LapodaTale_xxx.lng szövegfájlokban találhatók. Az xxx helyén a nyelvet azonosító hárombetűs kódok állnak. Most néhány szó az lng fájl felépítéséről: alapszabály, hogy bármit megváltoztathatunk értelem szerűen, de aminek hatásával nem vagyunk tisztában, ahhoz inkább ne nyúljunk! Szabály továbbá az, hogy a kezelőfelület nyelvi konfigurációját az alábbi szakasz tartalmazza:

PROJECT=Tale
LNG=ENG
LANGUAGE=english
FONT=Arial
CHARSET=1
BACKGROUNDS=backgrounds
101=Error
102=Warning
...

A nyelvi fájl lefordításánál ügyeljünk a tükörfordításra, a sorok elején lévő kódok a feliratokat azonosítják, azokat megváltoztatni nem szabad.
A szövegben esetlegesen előforduló %s vagy %d kódok a program által behelyettesítendő szöveges vagy számszaki adatokat jelölnek, ezek helye a nyelvi szórend miatt áthelyezhető.

A témakör bővítéshez a "mester" jogosultsággal rendelkező felhasználók a főmenü jobb alsó sarkában található bővítés nyomógombjával az alábbi felületre lapozhatnak. A bővítési lehetőségeket a fejlécen elhelyezkedő ikonokra (1-4) kattintva lehet elérni..

Nyelvek megadása (1)

A programban kiválasztható nyelveket az (5) listában láthatjuk. Ez a lista szabadon bővíthető, de törölni is lehet belőle a már nem használt nyelvet, a szemléletesség kedvéért a nyelvhez zászlót ábrázoló kép is rendelhető a (6) gombokkal.

Egy újabb nyelv hozzáadásához ezt a gombot megnyomva egy szövegbeviteli ablakban gépelje be a nyelv nevét, majd az elfogadása után megnyílóban a nyelv 3 betűs azonosító kódját. Ez a kód lehet pl. az ország sport vagy autó jelzése.
A feleslegessé vált és kijelölt nyelvet ezzel a gombbal lehet törölni egy megerősítő dialógus elfogadása után.
A nyelvek neve előtt a listában megjelenő zászló kép megadására szolgáló gomb. A megjelenő tallózó ablakban jelölje ki a használni kívánt képet, melyet (szükség esetén) a program automatikusan a megfelelő (36×22 képpont) méretűre alakít.

Háttér (2) és figura (3) képek megadása

Ez a két menüpont megjelenését és kezelését tekintve teljesen hasonlóak, ezért együtt tárgyalhatók.

A képen látható táblázat oszlopaiban a programban használt nyelveket, míg a soraiban a figura (illetve háttérkép) mappában található képeket látjuk. A táblázat celláiba a figura különböző nyelveken használt elnevezései kerülnek, melyek átírással módosíthatóak. A táblázat kezeléséhez használatos funkció gombok a táblázat jobb oldalán elhelyezkedő panelen kaptak helyet.

Új képet a táblázathoz adni a kék "+" gomb megnyomásával lehet. Ilyenkor egy képkiválasztó dialógus ablak nyílik, melyben rá kell mutatni az illető képre. A szükséges méret és formátum átalakítást a program automatikusan elvégzi. A figurák esetén a szükséges körbevágást a (4) felületen lehet elvégezni, melynek tárgyalása később következik. Egy képet az illető sor kijelölésével és a piros "-" gomb megnyomásával lehet. A táblázatban történt módosításokat a "floppy" gomb megnyomása menti el. Egy kép szerkesztéséhez a "ceruza" gombot megnyomva egy rajzoló felületre lapozhatunk.

Amikor egy új képet illesztünk a rendszerbe, az eredetiről egy másolat kerül a rendszer megfelelő mappájába, melyen a szükséges átalakításokat a program automatikusan elvégzi.

Képek szerkesztése

Azért, hogy a figurák a rajzlapon kontúrosan körbevágva jelenjenek meg, ezt a kontúrt külön meg kell adni. A figurákat a program PNG formátumban tárolja és használja. Ez a formátum rendelkezik azzal a speciális tulajdonsággal, hogy a körbevágás nem csak éles, hanem lágy szélű is lehet. A kontúr megrajzolásához az ábrán látható felület használható.

A gombok jelentése a következő:

(1) Alap üzemmód. Ez a gomb szolgál a (2) .. (4) üzemmódok kiváltására.

(2) Varázspálca. Ebben a rajzolási módban egy varázsütésre lehet kivágni az összes olyan részt, ami a rákattintott képponttal azonos színű.

(3) Ceruza. Éles kontúrral történő kivágáshoz használatos rajzeszköz.

(4) Ecset. Lágy széllel történő rajzoláshoz használatos rajzeszköz.

(5) Kivágás visszavonása. Tekintettel arra, hogy a PNG formátum a körülvágást teljesen külön képként kezeli, így lehetőség van az elrontott kontúr rajz alaphelyzetbe hozására, mivel a rajzeszközökkel a kép hasznos tartalmát nem módosítottuk!

A rajz elfogadása és elmentése a (10) gombbal történik, míg a (11) gombbal a módosításokat eldobva léphetünk vissza a kép táblázathoz. A rajzoláshoz az egér aktív pontjának koordinátái a (6) kijelzőről olvashatók le, a megfelelő nagyítási méret pedig a (7) csúszkával szabályozható. Fontos itt megjegyezni, hogy a nagyítási csúszka helyzete nem befolyásolja a figura valós méretét, csak a pontosabb körberajzoláshoz nyújt segítséget. A (8) gombbal a valódi mérethez, a (9) gombbal pedig az optimális nagyításhoz lehet igazítani a csúszka helyzetét.

Témakörök összeállítása (4)

A témakörök összeállítása – bár egy több dimenziós adathalmazról van szó – szinte gyerekjáték. Ugyanis csak annyit kell megadni, hogy mely képek, mely témakörökben szerepeljenek. Ha azt akarjuk, hogy egy figura vagy háttérkép valamely témakörben szerepeljen, a megfelelő adatrácsban egy csillagot helyezünk el a cellára duplán rákattintva vagy a szóköz billentyű leütésével. A kép kivétele a témakörből ugyanígy történik. Új témakör hozzáadása vagy egy meglévő törlése a nyelveknél és a képeknél megismert módon a "+" és "-" gombokkal történik. A módosítások mentésére a "floppy" gomb szolgál. Az egyszerűség kedvvért a táblázatban egyszerre csak egy nyelv adatai látszanak, de hogy melyik legyen ez a nyelv, a táblázat fölötti legördülő listából választható ki.


Mesemondó használata

Annak érdekében, hogy az elkészült mesénket más számítógépeken is megnyithassuk a tale fájlkiterjesztésű állományt kell magunkkal vinni. Igen ám, de ha az illető másik számítógépre még nincsen telepítve a Lapoda Mese program, a mese megnyitása nem fog sikerülni. Szerencsére a program kínál egy olyan megoldást, amellyel önállóan, vagyis a Lapoda Mese telepítése nélkül is megnyitható mesét készíthetünk. A 'trükk' abban áll, hogy a meséhez hozzá csomagoljuk a mese értelmezéséhez és megjelenítéséhez szükséges programot is. Ezt a műveletet végzi a LapodaTaleTeller program a mese állományokból futtatható exe állományok készítésével.
A LapodaTaleTeller program indulása után megjelenik a mese kiválasztó ablak. Itt 2 választási lehetőség adódik, melyek közül ún. rádiógombokkal lehet választani. Az első a kiválasztott mesét megnyitja, a másik pedig elkészíti a meséből az önállóan futtatható csomagot. A kiválasztott művelethez a mesét az ikonjára duplán kattintva lehet hozzárendelni.

Az átalakítás nem tart túl sokáig és már készen is van a mese állomány mellett annak nevével azonos exe kiterjesztésű program, amely a Windows-os programok megszokott módján indítható.

Futtatás paraméterrel

A TaleTeller program paraméteresen is használható. Ez annyit jelent, hogy az indításhoz járulékos információ is csatlakozik. A paraméterrel közvetlenül is megadható a mese fájl neve, valamint az, hogy futtatható állományt készítsen-e vagy nyissa meg. Pl. LapodaTaleTeller.exe /sajátmese.tale /MAKE.
Mivel az utasítás sor tagolója a szóköz karakter, ezért amennyiben a mese nevében is van szóköz, a mese nevét idézőjelek közé kell tenni a LapodaTaleTeller.exe /MAKE "van benne szpész.tale" alaknak megfelelően. A paraméterek sorrendje felcserélhető, ahogy a példából is látszik.

A hordozható mese megnyitásakor egy lecsupaszított kezelőfelület jelentkezik, amelyről hiányoznak a szerkesztési funkciók, hiszen az elkészült mese tovább már nem módosítható. (A mese módosítását az eredeti állományon kell elvégezni és a futtatható csomagot újra kell generálni.)

Az elkészült hordozható mesét a /FULLSCREEN paraméterrel indítva csak a "rajzlap" tartalma kerül a képernyőre, a fejléc, a mese szövege és a lapozó sáv is elmarad. Pl. sajátmese.exe /FULLSCREEN

Vezérlés billentyűzetről

Az elkészült mesét (ha több oldalas) a billentyűzet PgUp és PgDn gombjaival lehet oda-vissza lapozni. A mese az Esc billentyűvel vagy a jól ismert Alt+F4 kombinációval zárható be.


Beállítások

A paramétereinek és a felhasználók jogosultságainak beállítása

A program a „mester” jogosultsággal rendelkező felhasználók számára lehetőséget ad arra, hogy a számos beállítást megváltoztassanak.

Ezeket a lehetőségeket az alábbi lapon elhelyezkedő mezők és kapcsolók adják és valószínűleg az iskolai rendszergazdák és pedagógusok életét könnyíthetik meg leginkább.

Fontos megjegyezni, hogy LAN hálózatos használat során a konfigurálást csak arról a számítógépről és csak az a felhasználó végezheti, aki a programot feltelepítette.

Elérési útvonalak

Az itt található mezőkben rendre a háttér képek, a figurák, a hangfelvételek és a mesék tárolási útvonalát lehet megadni. Bár ezek az útvonalak kiindulásképpen a telepítési mappa egy-egy alkönyvtárára mutatnak, ezek módosíthatók. A módosítással pedig lehetőség van arra, hogy például egy helyi hálózaton megosztott könyvtárból érkezzenek a figurák vagy egy kijelölt szerver mappába kerüljenek az elmentett mesék. Az útvonalak beállításának egy speciális módja, hogy a konfiguráció számítógép × felhasználó szinten egyedivé tehető. Beállítható például, hogy egy adott gép felhasználói mely könyvtárakkal dolgozzanak, de megoldható az is, hogy egy adott felhasználó bármely gépről ugyanazt a beállítást használhassa. (Persze ez utóbbi eset feltételezi, hogy a számítógépekre az illető felhasználó bejelentkezése megoldott) A beállítások ilyen speciális alkalmazása már csak „kézi” módszerrel valósítható meg, s legtöbbször a rendszergazdák privilégiuma. A beállítások a program SYSTEM mappájában elhelyezett LapodaTale.ini szöveges fájlban vannak. A formátum a következő:

[GENERAL]

pathBackground=útvonal ; a hátterek elérési útvonala

pathFigure=útvonal ; a figurák elérési útvonala

pathSound=útvonal ; a hangok elérési útvonala

pathTale=útvonal ; a mesék elérési útvonala

Az útvonalak lehetnek relatív (a telepítési helytől kiinduló) vagy abszolút hivatkozások. A GENERAL szekció a „mindenki” számára érvényes beállítások helye. Ugyanebben a struktúrában azonban szerepelhetnek [COMPUTER.USER] alakú szekciók is. A computer a rendszerben jelenlévő egyik számítógépének bejelentkezési neve, a user pedig a regisztrált felhasználókat jelenti. Mind a computer, mind a user helyén szerepelhet * karakter, ami a „bármely számítógép”, illetve „bármely felhasználó” rövidítése. A *.* speciális eset a fent említett GENERAL szekcióval írható le. A specializált szekciók részbeni vagy teljes hiánya esetén értelem szerűen a GENERAL beállítás lép életbe.

Az útvonalakban használhatók dinamikus változók is, melyekkel lehetőség van különböző felhasználók eltérő profiljait kezelni. A program az útvonalakban található változó neveket a mindenkori valós értékekkel helyettesíti
%PERSONAL% | → | az aktuális felhasználó dokumentum könyvtára
%COMMON_DOCUMENTS% | → | a felhasználók közös, megosztott dokumentumainak mappája
%COMPUTER% | → | a számítógép hálózati azonosító neve
%USER% | → | a számítógépre bejelentkezett felhasználó azonosító neve

Például: pathTale=\\server\LapodaTale\%USER%\Tale

Meg kell említeni, hogy az útvonalak átállításával a mappák nem kerülnek át az új helyre, azokat manuálisan kell áthelyezni. Amennyiben az újonnan beállított mappák a program újbóli futtatásakor még nem léteznek, akkor azok automatikusan létrejönnek, sőt a hátterek, figurák, stb. a telepítéskor definiált helyről automatikusan átmásolódnak, azaz pl. több felhasználó esetén kópiák keletkeznek az egyedi útvonalakra.

Felhasználói jogosultságok

A programban számos funkció engedélyezésére, illetve tiltására van lehetőség. Ezeket a felsorolt bejelölő mezőkkel lehet vezérelni. Bár a lehetőségek magukért beszélnek, néhány szóval azért említést teszünk róla. Itt kívánjuk megjegyezni, hogy a beállítások egy része számos észrevétel, vélemény meghallgatása után szűrődtek le, ennek ellenére némelyik besorolható a ... "Hát ez meg mire kell!" kategóriába. Szerencsére használatuk nem kötelező, aki nem kívánja "piszkálni", az ne tegye! J

Nyelvválasztás engedélyezése: ezzel a nyitó lapon található "zászlós" nyelvválasztási lista működését lehet engedélyezni vagy tiltani, ha ez didaktikai megfontolásból fontos lehet.

Témakör választás engedélyezése: ez a kapcsoló a munkafelületen található témakör lista láthatóságát szabályozza, hogy kötött témájú foglalkozásokon a "tekergést" ki lehessen védeni.

Szó lista látható: ez a kapcsoló a témakörbe tartozó szavak listáját mutatja vagy éppen eltűnteti annak függvényében, hogy éppen az olvasás vagy az írás gyakorlása a pedagógus célja.

WEB használat engedélyezése (későbbi fejlesztésre fenntartva) : a program mese és figura készletének WEB-ről történő bővíthetőségének engedélyezése vagy tiltása.

Nyomtatás engedélyezése: a papírtakarékosság jegyében a beállításokat végző kezelő korlátozhatja a mese jelenetek kinyomtathatóságát.

Hanglejátszás engedélyezése: az órai hangzavar elkerülése érdekében korlátozható a meséhez csatolt hangfájlok lejátszási lehetősége.

Hangfelvétel engedélyezése: ennek a beállításnak hiányában a meséhez nem lehet hangokat felvenni vagy hozzáfűzni.

Automata lejátszás engedélyezése: itt arról van szó, hogy a meséhez hozzárendelt automatikusan induló hangok lejátszása egy (rövid) időn belül igen zavaró, ha az ember szerkeszteni akarja a mesét, s emiatt gyakran lapozgat ide-oda. Ennek a kapcsolónak az a szerepe, hogy a hangok ilyen formában történő lejátszását el lehessen kerülni. Természetesen a hangok "direktben" történő kattintással ilyenkor is lejátszhatók. A mesemondó használatakor (TaleTeller) a program ezt a kapcsolót figyelmen kívül hagyja, vagyis engedélyezi az automatikus lejátszást.

Haladó felhasználó kapcs. mutatása: a nyitólapon egy bejelölő mező megjelenését engedi vagy tiltja. A "haladó" módban a fájl dialógus ablakok az egyszerűsített forma helyett a Windows rendszerben megszokott "teljes értékű" formát használják.

Haladó felhasználó: üzemmód váltó kapcsoló az előző pontban leírtaknak megfelelően.

Indulási paraméterek:

Itt a program indulásakor automatikusan kiválasztandó nyelv és témakör adható meg.

A beállítások tárolására a jobb alsó sarokban található nyomógomb szolgál.